Sign in to follow this  
Followers 0

X100 Enthusiasts Is Now FujiXSeries.com

17 posts in this topic

Posted

As Fujifilm continues to expand the X Series family of cameras, I've decided that we should expand the X100 Enthusiasts community to include the new and upcoming models like the Fuji X10. With this change will come some minor rebranding and a renaming of the community from X100 Enthusiasts to FujiXSeries.com.

Later today the site's domain name will switch over to www.fujixseries.com, all existing links will continue to work, and all of the community content will automatically move to the new address. For those of you who follow us on Twitter, our twitter username has changed from @X100Enthusiasts to @FujiXSeries, and you will continue to receive our posts. It should be an easy transition! Once we are using the new domain name, you may need to log in to your account again.

Now that the Fujifilm X10 has begun to ship around the world, we'll begin covering Fuji X10 reviews, accessories, post processing, usage tips and more!

Thanks to everyone in the community for making this such a great forum to discuss and share our experiences with these awesome cameras! Your insight and advice is appreciated, and your photographs continue to inspire! Let's welcome the new wave of X10 users into our group!

Share this post


Link to post
Share on other sites

Posted

Good work!

A wise move IMO!

Share this post


Link to post
Share on other sites

Posted

great ill come whatever the name ....for ome reason i could not sign in and it was necessary to do a password reset

anyone else experence this? cant wait for your logo picture to have a camera on the other side of the x 100

Share this post


Link to post
Share on other sites

Posted

no password reset here.. needed to login for the browser/cookie to work...

nice move btw....

Im hopeful of the next camera in the series...

Share this post


Link to post
Share on other sites

Posted

Everyone will likely need to log in again, at least those with direct forum accounts. If you log in through Facebook or Twitter, it may continue to work on the new domain name. Sorry for the trouble @cosinaphile!

I'm excited for the upcoming interchangeable lens X series camera! I'm not sure if we'll be covering the Fujifilm X-S1 on the site or not, I feel like it doesn't quite fit in with the group, but if there's enough interest we can support it too!

Share this post


Link to post
Share on other sites

Posted

excellent +1 Like RT etc ;)

Share this post


Link to post
Share on other sites

Posted

Hi Chris, nice change...

Share this post


Link to post
Share on other sites

Posted

Let's move!

Share this post


Link to post
Share on other sites

Posted

Great idea for the name change Christopher. Personally though, I would like to see different sections in the Forum for the different X series cameras. One for the X100, another for the X10, and for the X??? and so on - like Nikonians does for example. I think it would be easier to find the stuff you want, and say the things you want and stay on topic that way. Just a thought!

Share this post


Link to post
Share on other sites

Posted

Hey @chroaz100! The forum actually does have separate sections for each camera's discussions, you can find links to them under the 'Categories' section in the right side column. It's difficult to notice though, our forum software works differently than most, and places all of the latest discussions on the homepage to help encourage participation. There are some overlapping categories for now, like post processing and accessories, but I think this works well for the smaller scale of our community. As the forum grows I'll continue to expand these categories, and make additional changes to help with the organization of separate camera discussions. One thing I would like to add is a 'prefix' before each discussion title, that shows which camera model it is about. For now though, I'd encourage everyone to use very descriptive titles when starting a new discussion :)

Thanks everyone for your support! I've really enjoyed watching our humble community grow since beginning in the middle of April, just before the great X100 was released. We have an incredible group of members here, and I appreciate everyone who has contributed to the community.

Share this post


Link to post
Share on other sites

Posted

Thanks Chris for the very wise move. I eagerly awaits too that next X1000 or whatever they will call it...

The very first login was complex, through that facebook stuff, but since then, no problem to relog here for me, with the same name and password.

By the way, nice iTouch/iPhone interface, simpler than the full site, still readable!

All the best,

Share this post


Link to post
Share on other sites

Posted

Thanks, Christopher, for all your work with this. The "prefix" idea of yours is a good one, and I have to admit I hadn't really noticed the categories on the right as I usually just "launch" from the Home page.

Great job, thank again.

Share this post


Link to post
Share on other sites

Posted

I never noticed the sections, tbh IM not sure what the hit rates are on this site, but the posts are of a nice manageable amount that I can read most/all of the posts even if theyre not immediately apparent that Id be interested - which is nice.

Share this post


Link to post
Share on other sites

Posted

I quickly became an addict of this forum. It is so useful and so supportive. Thank you again Chris.

Share this post


Link to post
Share on other sites

Posted

Thanks for the move, now we can fully support discussion about future Fuji X cameras.

BTW Chris, I have to refresh every page I look at under mac, or I keep looking at what's in my cache, not the most current state of the orum, except the threads were I just posted... I don't have this behaviour with other forums out there. When I come back to the main threads list, it's updated. Maybe there is an option for this when you manage the forum? I don't know if other users experience this. I'm under Mac OSX 10.6, Safari.

All the best, and thanks again!

Share this post


Link to post
Share on other sites

Posted

@gregvds, it seems to be an issue with Safari's overzealous cache. Try clicking on the Fuji X Series logo up top to return to the home page, instead of using your browser back button.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0