Search the Community

Showing results for tags 'flash'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • Fuji X Community
    • General Discussion
  • Fuji X System
    • Fujifilm X-Pro2 • X-Pro1
    • Fujifilm X-T2 • X-T20 • X-T1 • X-T10
    • Fujifilm X-E2 • X-E1
    • Fujifilm X-A3 • X-A2 • X-M1 • X-A1
    • Fujifilm X Mount Lenses
  • Fuji X Compact
    • Fujifilm X100F • X100T • X70 • X100S • X100
    • Fujifilm X30 • X20 • X10
    • Fujifilm X-S1 • XQ2 • XQ1 • XF1
  • Fuji X Accessories
    • Bags, Cases, Straps & Grips
    • Lighting, Flashes & Filters
    • Batteries, Chargers & Memory Cards
    • Tripods & Other Accessories
    • Gear Reviews
  • Digital Darkroom
    • Post Processing
    • Photo Gallery
  • Marketplace
    • Classified Ads
    • Hot Deals

Group


AIM


MSN


Website URL


ICQ


Yahoo


Jabber


Skype


Location


Interests


Camera List


Lens List

Found 18 results

  1. I recently had my camera cleaned. Now the flash doesn't work at a photo expo event, so I can't return to the store for redress. I've set the camera on mechanical shutter. Any other suggestions?
  2. Hi 🙋🏻 I think my built in flash is struggling to sync with the shutter of my x-a2. Whenever I use it I get half the photo in darkness. Is there a shutter speed limit? Is it a firmware problem? Am I just being an idiot? Ta for any help. liz
  3. Just wondered if anyone is using a Meike MK320 on there Fuji X-T1 ? If so is there any issues with it and the latest firmware as I have read elsewhere that the Nissan i40 won't work correctly and has to be sent away for a firmware upgrade ? So would this also apply to the Meike MK320 ? thank you in anticipation 😊
  4. Fuji XT2 with Cactus V6 II & Canon 600EXRT Does anyone know if I can have the Cactus V6 II trigger on the XT2 and then a Cactus V6 II trigger on a Canon 600EXRT flash and they will work in all modes including HSS.
  5. Hello Can anyone tell me if the Cactus RF60 flash will work with the Fuji XT2 in high speed sync mode while it's on camera. All I can seem to find out is that it works off camera in high speed synce while using the Cactus V6 trigger. Thenks
  6. Hello I tried to use my Canon 600RT flash with my Fuji XT2 in full manual mode on camera with the shutter set at 250 and below. Then set my Canon 600RT flash into manual mode and adjusted the zoom coverage to my lens focal length. But I just can't get the Canon flash to fire while on the XT2 for some reason. So has anyone got any idea why it won't fire as it should do in manual mode. There must be something in firmware of the flash or the camera preventing the flash from firing. So anyone else tried using a Canon flash on the XT2 or any other Fuji camera and had the same issue. As of now I don't have any other flash apart from the little one that comes with the XT2 and that fires just fine.
  7. Good day everyone, Anyone can confirm if the Phottix Odin II (the new one) transmitter works on Fujifilm X cameras? At the very least, will it enable dumb triggering, or even better, manual remote power control? Understood that TTL will not work due to compatibility, but I don't need TTL. The old Odin TCU was confirmed not to work, and I'm hoping the second version fares better. Looking to use the Odin system for both my Nikon and X100S.
  8. Hello! I am hoping that someone can help me to use my speedlight (Yongnuo 568EX) at shutter speeds faster than 1/500 sec on my new x100T. I am triggering with the Yongnuo 603C (version 1). I don't know if the problem is with the flash, the trigger or my settings. I set the settings as I'd read (turn off Silent Mode, turn off Preview Exposure, use Mechanical Shutter, set to External Flash, etc.) but I am loosing the flash once I set it to 1/1000 sec, and I don't know what else to do. I appreciate any assistance you all might be able to offer. Thanks in advance! Steve
  9. Hello! I am hoping that someone can help me to use my speedlight (Yongnuo 568EX) at shutter speeds faster than 1/500 sec on my new x100T. I am triggering with the Yongnuo 603C (version 1). I don't know if the problem is with the flash, the trigger or my settings. I set the settings as I'd read (turn off Silent Mode, turn off Preview Exposure, use Mechanical Shutter, set to External Flash, etc.) but I am loosing the flash once I set it to 1/1000 sec, and I don't know what else to do. I appreciate any assistance you all might be able to offer. Thanks in advance! Steve
  10. Hi I have question for people who are using Meike MK320 flash with fujifilm x-t1. Previously I used it with x-pro1 camera and manulal lenses and it was working flawlesly in TTL mode. I've set up 1/60 of second and lowest possible ISO. When I shoot photos the flash unit fired single pre-flash to make the calculations and another to lighten the scene. Now I have X-T1 and Mk320 desn't make pre-flash. It works fine with XF lenses because they transfer f-stop data to flash unit automatically but with manual lenses there is a problem. I can't belive that potentially higher level camera can't do pre-flash. I think I'm doing something wrong but I don't know what. Someone had the same problem?
  11. Hello, It's my first post, and I honestly have a great hope in finding the right answer. Before posting anything, I did Google the problem. And I didn't find any reasonable answer. I got the Metz 36 AF 4 flash for less that 25Euro (NOS) It works fine with Canon 650d, but I wanna use it in manual mode with Fujifilm XE 2. Nomatter what I do, I cant make it flash with Fuji. Is there any checklist of settings that I should do, in order to make sure that my Fujifilm XE 2 is set up correctly in order to work properly with an external flash in manual mode? AFAIK, any external flash that has safe voltage, should work a least in manual mode. Any advice is appreciated.
  12. Hi All, The XT-1 came with a small flash, but I will need a proper one sooner or later. I was thinking of getting a "Yong Nuo". Any opinions on this please? Or suggestions for anything different? Meanwhile, someone I know gave me a video lamp - specifically a "Cullman Video Lamp CL 200". This was previously used for video shooting. It does not have a hot shoe - basically its just a lamp with a diffuser and the light lasts for 17 minutes. I would like to ask whether this sort of lighting is a viable alternative to a flashgun. Common sense would seem to indicate that a constant light source would be easier for the camera in terms of calculating exposure etc? Thanks. John
  13. Just purchased X100t as my "take everywhere" camera. Tired of lugging my 5DIII around. I'll be at a series of indoor and evening events where I'll want to take candids and fun portraits of people and I want to use on-camera flash. I don't want to hook up my Nikon Speedlight on manual (too big), so wondering what people are liking as best options for small flash? Is the Fuji EF-X20 the best option? From reviews, looks like it might recycle slowly? I'm perfectly fine with manual settings, TTL is nice, but not required.
  14. X-A2, flash is disabled, flash menu item is disabled. Other threads say check Silent Mode, however I confirmed Silent Mode is off. What are the other options for enabling flash option?
  15. Using a Fujifilm X-M1 camera and recently purchased an EF-42 shoe mount flash. I was able to use it successfully a couple of times, but now the flash doesn't go off when shooting. I tried different settings, auto, manual and others and the flash just doesn't go off. The flash does respond to the camera, adjusting in TTL mode, to when I zoom, shuts off when I turn off the camera, so obviously they are communicating. I tried using a buddy's canon flash on my camera, which didn't work, however, my flash worked on a Canon body. Not sure what I am missing, certainly hope it is just a setting. Appreciate any help, thanks in advance.
  16. Hi, I bought the Fuji EF-42, but no flash stand came with it. I can't seem to find a specific stand online for this flash model. Can anyone help? Thanks
  17. Hi, Was wondering what the flash setting should be on the X-T1 when used with the EF-42TTL ? Thanks!
  18. Hey I've been experimenting recently using 1/4 CTS gel over the ef-x20 flash on my Fuji X30 and been getting some mixed results. On some images the effect of the gel is clear/has the desired effect while on others it's like the gel has been completely bypassed (despite it tightly covering the flash) and the output image suggests a normal flash with no gel on at all. As unlikely as it seems, is there any reason this would be happening due to camera settings etc? If not any other suggestions as to why it might be occuring?