Jump to content

Search the Community

Showing results for tags 'speedlight'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • Fuji X Community
    • General Discussion
  • Fuji X System
    • Fujifilm X-Pro2 / X-Pro1
    • Fujifilm X-T2 / X-T20 / X-T1 / X-T10
    • Fujifilm X-E2 / X-E1
    • Fujifilm X-A3 / X-A2 / X-M1 / X-A1
    • Fujifilm X Mount Lenses
  • Fuji X Compact
    • Fujifilm X100F / X100T / X100S / X100 / X70
    • Fujifilm X30 / X20 / X10
    • Fujifilm XQ2 / XQ1 / XF1 / X-S1
  • Fuji X Accessories
    • Bags, Cases, Straps & Grips
    • Lighting, Flashes & Filters
    • Batteries, Chargers & Memory Cards
    • Tripods & Other Accessories
    • Gear Reviews
  • Digital Darkroom
    • Post Processing
    • Photo Gallery
  • Marketplace
    • Classified Ads
    • Hot Deals

Group


Website


Flickr


Instagram


500px


Location


Interests


Camera List


Lens List

Found 2 results

  1. Fuji XT2 with Cactus V6 II & Canon 600EXRT Does anyone know if I can have the Cactus V6 II trigger on the XT2 and then a Cactus V6 II trigger on a Canon 600EXRT flash and they will work in all modes including HSS.
  2. Hello! I am hoping that someone can help me to use my speedlight (Yongnuo 568EX) at shutter speeds faster than 1/500 sec on my new x100T. I am triggering with the Yongnuo 603C (version 1). I don't know if the problem is with the flash, the trigger or my settings. I set the settings as I'd read (turn off Silent Mode, turn off Preview Exposure, use Mechanical Shutter, set to External Flash, etc.) but I am loosing the flash once I set it to 1/1000 sec, and I don't know what else to do. I appreciate any assistance you all might be able to offer. Thanks in advance! Steve
×