Jump to content
Pauline Beluso

XA10 camera flash wont work

Recommended Posts

Hi All!

So my XA10 flash does not work. I tried searching it on forums for any possibility of solution for this but unfortunately it wont work.

One of the possibilities is it might be on silent mode stuff like that... I tried but not.

Also on Q part, flash is not highlighted.

Thanks! Hoping some could help me with this! :)

 

Share this post


Link to post
Share on other sites

Does the camera have a macro mode? If it does make sure it is off. Some of the early Fuji X cameras will not use flash in macro mode.

Also make sure you are not is some sort of special effects mode or even AFS-C. Try to make the camera set up as basic as possible. If you can't find the issue try resetting the camera to factory default. How to do it is in the user manual and if you don't have that the manual can be downloaded from Fuji.

Note that it says this in the user manual "The flash modes available vary with the shooting mode."

  • Like 1

Share this post


Link to post
Share on other sites

Check the menu item "Sound and flash off" Turn it on. Here's the rest of the flash faults.

The flash can not be used at current settings: See the list of the settings that can be used with the flash.

The flash is lowered: Raise the flash.

The battery is exhausted: Charge the battery or insert a fully-charged spare battery.

The camera is in bracketing or continuous mode: Select single frame mode.

OFF is selected for SOUND & FLASH: Select ON.

  • Like 1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recommended Discussions



×