Jump to content
goop

X20 stopped working (does not turn on)

Recommended Posts

I have an X20 that I bought from a friend about one and a half years ago (don't know when he bought it, but it's probably at least four years old). A couple of weeks ago it suddenly stopped working (nothing happened when I tried to turn it on). I have tried both the regular "on-switch" and the preview button, as well as different batteries and checked the battery voltages to make sure the charger works. The camera does not react at all. Any ideas about what the problem could be? Is there anything else I could try?

Grateful for any suggestions!

Share this post


Link to post
Share on other sites

If I recall the X20 turns on via twisting the lens barrel? Have you tried turning it on while holding down the DISP/Back button, as if you were initiating a firmware update. If the camera display not power on, unfortunately it will have to get sent in for repair. Is it possible the rear LCD stopped working? Is there any indicator inside the X20's OVF when it is 'on'?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recommended Discussions



×