Jump to content

Fujifilm X-A2: shutter button doesn't work

Recommended Posts



I have a X-A2 with a Minolta 50mm f1.7 with an adapter on it.

I can't release the shutter button, the camera won't take a photo.

When pressing the button, the green indicator light is blinking as usual when you take a picture. In the menu I have set " Shoot Without Lens" to "On". I am able to take videos, because for that I have to press another button. Furthermore I have tried every mode on the dial. Sadly I don't have an original (expensive) X-Mount lenses so i can't try these out.

Update: I have even tried the self timer and it did not work either, so maybe its not the shutter button...

I will be happy with any answer I am getting, so thank you a lot in advance!



Share this post

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Recommended Discussions

  • Create New...