Jump to content
Sign in to follow this  
Ammarly

Turn on Fuji Xe2 and always appears Start Menu(languages and set time) and reset my configuration

Recommended Posts

Ammarly

Hi guys, hope everyone is doing great with these unprecedented times. 

 

I am really having a hard time with my Fuji XT-20, each time when I turn it on it takes me back to the Start Menu (languages and set time) and it resets my whole camera settings. This is really bad and sad since I don't have any services office in my country so I don't know what to do. I updated my frameware for both body and Lens and yet, it still shows take me back to the Start Menu when I turn it on. 

 

Please, anyone who had this issue before and fixed it please help me work this out. 

 

Thank you. 

Share this post


Link to post
Share on other sites
Photo Shooter

Usually when this happens it it because the internal battery or capacitor that is used to retain camera settings memory has failed.This is not a user fix. These days it will most likely require a replacement main control board inside the camera.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

  • Recommended Discussions



×
×
  • Create New...