Jump to content

Flash settings stuck on Sync Terminal on XT2


Recommended Posts

Hello. I just acquired a EF X20 Flash. I put it on the hot shoe but my XT2 (firmware 4.40) recognizes it as in sync terminal. So I can only acces the Manual mode (the TTL Mode in Flash Settings is grayed out). The flash does fire on Manual, but the TTL is not working.

When I put the EF X8 Flash, it simply does not even fire.

I am on single shot and mechanic shutter.

Any ideas what might be happening?

Thanks a lot!

IMG_2969.jpg.8e8333e0450ecc7f6a9da27de9db3a34.jpg

Link to post
Share on other sites
  • 1 month later...
camerashub

 If you pair this camera with the best Flash, you will have a professional photography kit at your disposal.Almost every modern cameras have a built-in Flash, which is useful in every shooting situation, but built-in flashes cannot beat the quality and perfect lighting control of an external flash. I suggest Click Here for best quality flash and Top-Quality cameras.

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.



×
×
  • Create New...