Jump to content

Fujifilm X100 Firmware 1.21 Update Now Available


Christopher

Recommended Posts

Spent the day playing with 1.21, manual focus ring is slower, and still focus hunting on anything except most contrasty setting. Disappointment... as shooting mf, and autofocusing with ae/af button used to be so satisfying. Anyone else had poor resluts with this update?

Link to comment
Share on other sites

  • Replies 78
  • Created
  • Last Reply

i was very apprehensive about this firmware 1.20 was a disaster , and 1.21 appears

24 hours later, more or less ......really ?

i just have learned to live with the x 100 this past time and accepted its limitations and quirks ... do i really want new softwafre at this point ?

especially as it has the potential to diminish the camera while it corrects certain faults?

i did 1.21 last night , and it all my preliminary testing , the x 100 is a much better snappier camera as a result

in both af an mf modes , and less hunting in low light in mf.... alot less.....

im very pleased

Link to comment
Share on other sites

wrong about +5 mm blade away and hard to measure exposure, always in the same conditions otherwise I have to add about +2 EV version 1.11-13 I had the best photo

Link to comment
Share on other sites

@MMartin, it sounds like you may be experiencing the 'sticky aperture blade' issue, where your aperture blades are not opening to the right size. If this is the case you will need to send your camera in for service.

Link to comment
Share on other sites

tb1

I found the manual focus to be much better on 1.21 with AEL/AFL. I would make sure that you formatted the SD card before copying the image onto the card and placing into camera and doing update as I see that Fuji does not rename files and perhaps there is an old 1.20 file on the SD card that is creating conflict.

Link to comment
Share on other sites

Please can someone help me, i feel a little stupid!

I am trying to download the latest firmware for my fuji x100, but when i go on fuji,s website, i press firmware, but the page does not load it just stays blank, i have tried clicking on the link on this page, but nothing.

Thank you.

Link to comment
Share on other sites

  • 2 weeks later...

Please help with an interpretation of "Copy the FPUPDATE.DAT file to the root directory of the SD card." Am I placing it in the root directory when I drag the unzipped file onto the image of my SD card when using a Mac?

Link to comment
Share on other sites

I have read numerous posts on 1.21 and the vast majority report that it is an improvement over previous versions. If there were serious flaws in 1.21 we would continue to see negative posts, but we don't. I installed 1.21 when it first came out and it has worked to specification ever since. I suspect that any issues previously reported have had an element of user error.

Link to comment
Share on other sites

I have read numerous posts on 1.21 and the vast majority report that it is an improvement over previous versions. If there were serious flaws in 1.21 we would continue to see negative posts, but we don't. I installed 1.21 when it first came out and it has worked to specification ever since. I suspect that any issues previously reported have had an element of user error.

Thanks Greyelm! Your answer makes me happy before my tomorrows purchase. I can't wait!

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.


×
×
  • Create New...