Jump to content
Sign in to follow this  
MikeEvans

Case of the disappearing viewfinder grid

Recommended Posts

MikeEvans

I've had my X-Pro for three weeks and have noticed an odd happening in relation to the information displayed in the OVF. I have the camera set to show the grid and horizon. However, from time to time the grid/horizon overlay disappears for the day and I can see no rhyme nor reason in this. Obviously I've powered on and off, removed the battery and so forth. The grid will suddenly reappear and then vanish again for no apparent reason. Has anyone else suffered this? Maybe it is something pretty obvious that I'm overlooking. But I never had this behaviour on my X100.

If anyone is interested, I did a first-impressions review of the X-Pro on my tech blog, MacFilos. I had been thinking of buying a Leica M9; now I've had second thoughts.

Share this post


Link to post
Share on other sites
brickst3r

I think it might have something to do with power save mode, I think if it's on it might disappear? I'm not really sure I don't even have my XP1 yet. I read somewhere that might be the cause. But Someone more informed will know best.

Share this post


Link to post
Share on other sites
MikeEvans

Thanks for this good suggestion. However, I have tried it and still no grid or electronic level. Since I posted yesterday the two items have gone completely. They show in the EVF and I have confirmed that the relevant boxes are ticked in the OVF custom settings. Bit of a mystery, but it doesn't stop me enjoying the camera. Maybe it is some form of firmware glitch.

Share this post


Link to post
Share on other sites
nobody

are you sure you are in the right "view mode"? sounds a lot like you are in the "standard" view mode. Try pressing the view mode button until you are in "custom" mode.

Share this post


Link to post
Share on other sites
MikeEvans

Thanks to both of you. In response to RogerRabbit, it seems to make no difference whether I am in AF-S or AF-C. I mostly use S

For Nobody, I confess I'm confused about "standard" and "custom". As far as I am aware, the View Mode button toggles between 1) LCD, 2) Eye-Sensor and 3) Viewfinder. I always have it set to viewfinder since I hardly ever need the LCD and I hate the eye sensor. I have toggled these settings and nothing brings back the grid and the electronic level.

As a last resort I suppose I shall have to reset the camera, but I'm reluctant to lose the custom settings I've entered.

Thank you for your input. The more I think about this, it must be caused by something minor and very obvious. I have had a full day's shooting today and the OVF display is still missing the grid and horizon, although other parameters are shown.

Share this post


Link to post
Share on other sites
donp

In OVF mode if you hold the front lever more than two-three seconds it will slide the magnified lens into the viewfinder. Hold it again to get back to the framelines. No need to reset. Credit to sabastien.b on StackExchange.

:Don

Share this post


Link to post
Share on other sites
MikeEvans

Cracked it! I took the unusual and unaccustomed course of actually consulting the manual. On page 21, relating to the OVF, I find that the grid and horizon can be turned on and off using the Disp/Back button. This isn't very intuitive but it's obvious I've been pressing it inadvertently. Thanks to all of you for your time on this. There's a certain satisfaction in solving a problem like this....

Share this post


Link to post
Share on other sites
MikeEvans

Thanks, Don, that's something else I didn't know about the magnified view and I will undoubtedly find it useful. But it doesn't change the display of the grid, it's the Disp/Back button that does that as I outlined above. Thanks again for all your input.

Since posting this, I had a play with the magnified view. Can you explain a bit more? As far as I can see, when I hold the lever the frame reduces from the 35mm view (which corresponds to the lens fitted) to the smaller frame I see when I attach the 60mm lens. I don't see any magnification as such. Maybe I'm missing something here.

Share this post


Link to post
Share on other sites
Brad_D

Yay!!! Problem solved!! I recently purchased the fujifilm X-E1 and was having the same issue re the framing grid not showing up in the viewfinder. Found your post, Mike, about turning the grid on & off using the Disp/Back button, tried it on the X-E1 and it worked!!!! Frustration ended!!! Thanks a million, Mike! :-)

Share this post


Link to post
Share on other sites
Didymus

Thanks from me, too! I just hit this problem with my X-E1 - I had no idea why the level disappeared from the viewfinder, when it was still visible on the screen. Always read the manual, eh? :-)

Share this post


Link to post
Share on other sites
WillsPhotoimaging

Just experienced this problem and a quick search pulled up this clear solution / explanation :).

Share this post


Link to post
Share on other sites
RJD

Thanks. I was having the same concern with my XM-1 but your info solved it for me too.

You would think though the menu should set the lines or refer to the display button function?

Share this post


Link to post
Share on other sites
MrBeastie

Hi

I met up with this problem and solved it by coming here. I now have an X-M1 as well as an X-E1. My question is is there a level on the X-M1 like the X-E1, as that is not showing up in the screen?

Share this post


Link to post
Share on other sites
K1W1_Mk2

I'm not sure whether there is a level on the X-M1 but if there is it will mot show by default. You will need to go into the advanced display settings and see if you can turn it on there.

Share this post


Link to post
Share on other sites
JCD

This solved my problem of the disappearing box .... in July 2020 (on an XT-30).  History is useful, we all learn from it.

  • Like 1

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

  • Recommended Discussions



×
×
  • Create New...