Jump to content
Sign in to follow this  
OrvilleTheCat

New X10 with old serial number/sensor

Recommended Posts

weisgrau

Yes @beachcaster - you're good to go. :-)

Yes, it is good news. It means you camera has the newer sensor that does not have the white orb problem of the older sensors.

Share this post


Link to post
Share on other sites
scottshu13

Just got a new x10 from amazon ($309!!!) but I have a serial number of 22A. Should I be worried?

Share this post


Link to post
Share on other sites
burpo

Hi guys, new x10 user here. I bought this camera from Amazon 1 month ago with a good deal (249euros). I read a lot about it before buying and I was sure I received a new sensored camera. But in these days I'm in vacation in Florence and did very good day shots. I've also tried it by night and here's the question: the sn starts with 24M but the pictures looking like there's still a white orbs problem. I'm a newbie in photography, that's why I need your help. Here is the link for looking at a picture. It was taken by phone at the camera display because I haven't any computer now. Need to know if there are orbs or not. For me yes. http://dropcanvas.com/dqsup/1 thanks

Share this post


Link to post
Share on other sites
veejaycee

@burpo

As I understand it this is a picture taken by a phone of the rear LCD screen of the X10?

You need to provide a picture direct from the X10 otherwise there are too many unknowns and for all we know the orbs are from the phone. Note that the topmost orb-like flares (above the image) are of the settings display so they originate from the phone not the camera. With the serial number 24M you should be okay but best to try to upload an image direct from the X10.

Vic

Share this post


Link to post
Share on other sites
boulevardier

A 24 series X10 with orbs is most unlikely IMO. Many digital cameras can be made to show orbs under extreme circumstances.

Share this post


Link to post
Share on other sites
burpo

Ok guy, now I can upload the picture.

fnrj.jpg f11, 30sec, iso 100

2iyt.jpg f2.5, 1.5sec, iso 100

Am I wrong about orbs? Thank you for suggests!

Share this post


Link to post
Share on other sites
K1W1_Mk2

They don't look like orbs in the sensor issue sense of orbs to me. Particularly the first photo. Maybe it's just the very bright lights and a 30 second exposure. Cameras with orbs had a much more defined edge to the orbs from memory.

Share this post


Link to post
Share on other sites
nippa

I agree with kiwi , they're not orbs

Camera looks like it has the newer sensor.

Orbs were like sharp white circles totally unnatural and especially nasty when coming from reflected sunshine off metal objects.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

  • Recommended Discussions



×
×
  • Create New...