Jump to content
saruman

x30 flash always off

Recommended Posts

I've just bought a x30 but I'm not able to make the flash works.

No matter which mode is selected, the flash is always suppressed.

I've tried either the right selector and the flash setup in shooting menù, and I can access only the compensation but not the mode that is always, as said,suppressed.

Is my camera faulty or is it a general issue?

Share this post


Link to post
Share on other sites

Could it be that you have activated silent mode turning off all sound AND the flash? On Fujifilm cameras typically you press and hold the DISP/BACK button to toggle the silenst mode on and off.

Share this post


Link to post
Share on other sites

Thanks, but this isn't the problem.

I've checked this but it's ok.

I've tried to reset the setup but again this hasn't solved.

I haven't tried to upgrade the firmware because it does fix another kind of problem but maybe I can give it a try.

Is it possible to opena ticket with Fuji? I'm new with this brand so I don't know how this kind of things wors.

Share this post


Link to post
Share on other sites

Fuji cameras some times do things that are not well documented in the manuals. One action or menu setting causes a second setting to cease being available. It is usually logical when you work it out but often frustrating until you do.

You might have turned something on that disables the flash ( as mentioned silent mode is one thing that does it, I think burst mode also does on some cameras). The best thing to do right now is to reset the camera to factory default as per the manual one more time then check whether flash is working prior to making any other adjustments. If it is not then contacting Fuji will be the next step.

Share this post


Link to post
Share on other sites

It has worked

I reset the camera to default (this time also the shooting settings) and it worked

Probably it's the burst mode that I somehow activated that inhibits the flash

Thanks to everyone for the prompt support. :)>-

Share this post


Link to post
Share on other sites

Check the drive mode. I had the same problem and found if the drive mode was in one of the multiple continuous shot modes it would not fire and in the menu I couldn't select flash mode only compensation. Change the drive to still image (the top setting in the drive menu) The flash should work now.

Share this post


Link to post
Share on other sites

I stumbled upon this page as I was going crazy trying to figure out why I could not get my X30 to fire the flash through the hotshoe. (I am using off camera flash through a radio remote.) The replies on this post got me to look at what I might have turned on by accident. And I then noticed a little yellow flower with a magnifying glass on the left side of my screen. I had no idea what it was but suspected it looked like a macro sign. Sure enough, I pressed the macro button on the back of the camera, that icon disappeared and the flash fired right up!

After testing this a little more, I noticed that if you have it set to normal macro (one press of the button), the flash fires. But if you have it on Super macro (two presses of the button) the flash will not fire.

This is a really frustrating thing because it is easy to hit that button accidentally and not notice it because it does not change anything in your normal shooting.

Thank you to the other repliers for sending me down this path!

Share this post


Link to post
Share on other sites

Hi!

I bought a Fuji X30 a few days ago and was facing this issue with the flash too, so I'm going to tell you what I did to make my camera's flash fire.

First, I realised that it was in silent mode, like all of you said. Second, that the Selector button, whenever I pressed to select Flash, Macro, etc, was always selecting the focus area instead of the flash or other settings. 

So here goes what do you need to do, step by step: first, turn on the camera, then click on the "Menu/OK" button -> scroll down until you get on the Set-up (blue menu) number 1, press Menu/OK -> choose Silent Mode and turn it "off" -> then, go back to the blue menu and select the number 2 (or just scroll the screen down till you get on the SELECTOR BUTTON SETTING) -> change the selection from "Focus Area" to "Fn BUTTON".

Done! Now you'll be able to use your flash, or the macro mode, etc, by clicking on the 4 buttons around the Menu button. Just pop up the flash and be happy for finally being able to select what you really wanna use on the Selector Buttons. You'll be able to choose if you want the flash on or off and other choices.

Sorry if my English is not correct, but I hope I could help another customers like me that just couldn't understand why the flash wasn't working properly. ;)

Edited by Bárbara
  • Like 2

Share this post


Link to post
Share on other sites

Hi @Bárbara, thank you for the step-by-step walk-through. I've owned an X-30 for a little over a year now, and it's only today that I realized I needed the flash . . . and it's not working. No matter what I pressed/ toggled, nothing seemed to work. I was this "close" to hitting "Reset" when I stumbled into this site. The flash is working now! Happy New Year!

  • Like 2

Share this post


Link to post
Share on other sites
7 minutes ago, The Writing Commuter said:

Hi @Bárbara, thank you for the step-by-step walk-through. I've owned an X-30 for a little over a year now, and it's only today that I realized I needed the flash . . . and it's not working. No matter what I pressed/ toggled, nothing seemed to work. I was this "close" to hitting "Reset" when I stumbled into this site. The flash is working now! Happy New Year!

I'm glad to hear that it worked for you! How nice! That's an awesome little camera, though I don't usually use the flash I want it to be working when I need it, lol... I didn't know that step by step tutorial was helpful until today, and I'm really glad it was. 

A happy New Year! 

  • Like 1

Share this post


Link to post
Share on other sites

To use the camera silently AND have the flash operational, silent mode needs to be off to enable the flash. Then you need to turn off operation volume and shutter volume in sound set up in toolkit 2.

Share this post


Link to post
Share on other sites

I’ve tried all of these measures, to no avail. The orange light flashes when I raise the flash and the shutter button ceases to function. I’m fairly sure that I have fiddled with functions beyond my comprehension, but it’s left me a little exasperated, since now I cannot even find how to restore factory settings. If anyone out there were able to advise without being inordinately bored by the crass character of this request, I’d be most grateful.

Share this post


Link to post
Share on other sites

Did you try a simple web search?

X 30 Factory Reset:

  • Press the [MENU/OK] button
  • Press the [</ dial left] button to highlight the tab
  • Press the [V/ dial down] button to highlight the “wrench” icon
  • Press the [>/ dial right] button to place the cursor in the setup menu.
  • Highlight “RESET” and press the [>/ dial right] button
  • When a confirmation dialog appears, select “OK” and then press [MENU/OK] button
  • Once you've tried that, see if the flash works and get back to us if not.

Share this post


Link to post
Share on other sites
On 1/4/2019 at 8:46 PM, veejaycee said:

Did you try a simple web search?

X 30 Factory Reset:

  • Press the [MENU/OK] button
  • Press the [</ dial left] button to highlight the tab
  • Press the [V/ dial down] button to highlight the “wrench” icon
  • Press the [>/ dial right] button to place the cursor in the setup menu.
  • Highlight “RESET” and press the [>/ dial right] button
  • When a confirmation dialog appears, select “OK” and then press [MENU/OK] button
  • Once you've tried that, see if the flash works and get back to us if not.

I’m afraid I’ve tried this repeatedly, as well as the other methods suggested above, to no avail. The flash does not work on my X30. I am very fond of the camera, but this is an exasperating flaw. How, incidentally, does one turn off bracketing? This doesn’t seem possible using the menu. If there were a fix not alluded to above, I’d be most grateful to know it. Many thanks.

Share this post


Link to post
Share on other sites
On 1/23/2015 at 12:20 PM, presssnapper said:

Check the drive mode. I had the same problem and found if the drive mode was in one of the multiple continuous shot modes it would not fire and in the menu I couldn't select flash mode only compensation. Change the drive to still image (the top setting in the drive menu) The flash should work now.

How is the “drive mode” labelled on the camera itself, please? There is no “drive mode” on any of the menus. 

On 1/23/2015 at 12:20 PM, presssnapper said:

Check the drive mode. I had the same problem and found if the drive mode was in one of the multiple continuous shot modes it would not fire and in the menu I couldn't select flash mode only compensation. Change the drive to still image (the top setting in the drive menu) The flash should work now.

Aha, yes, I’ve now located this; my apologies for a little vacuity there. That said, the flash still doesn’t work. Many thanks, all the same. L

Share this post


Link to post
Share on other sites

When I raise the flash, this entails the unintended and unhelpful consequence of rendering the shutter button entirely ineffectual. This is accompanied by a flashing orange light, which occasionally switches to a flashing red light, as if attempting to communicate something to me with increased urgency, whilst failing to take stock of the incomprehensibility of the signal, as an American tourist might if he were merely to raise his voice in a conversation with a Strasbourgeois bank teller without endeavouring to change his language to French, German or Elsäßisch and thereby making himself intelligible, a lamentable scenario I once witnessed. 

Share this post


Link to post
Share on other sites
19 hours ago, Lyndon said:

I’m afraid I’ve tried this repeatedly, as well as the other methods suggested above, to no avail. The flash does not work on my X30. I am very fond of the camera, but this is an exasperating flaw. How, incidentally, does one turn off bracketing? This doesn’t seem possible using the menu. If there were a fix not alluded to above, I’d be most grateful to know it. Many thanks.

Bracketing is on the Drive button - on the back of the camera next to the trash button. Press the Drive button and highlight the top Camera icon for single shot. (No bracketing.)

Share this post


Link to post
Share on other sites
6 hours ago, veejaycee said:

Bracketing is on the Drive button - on the back of the camera next to the trash button. Press the Drive button and highlight the top Camera icon for single shot. (No bracketing.)

Many thanks, I’ve now done this, but am still experiencing problems. The flash, when raised, incapacitates the shutter button in all modes & a red light flashes unless I turn the camera off and on again. I have reset the camera, but the problems persist. 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recommended Discussions



×