Jump to content
Zgubior

Meike mk320 flash for x-t1 with manual lens

Recommended Posts

Zgubior

Hi

I have question for people who are using Meike MK320 flash with fujifilm x-t1. Previously  I used it with x-pro1 camera and manulal lenses and it was working flawlesly in TTL mode. I've set up 1/60 of second and lowest possible ISO. When I shoot photos the flash unit fired single pre-flash to make the calculations and another to lighten the scene.

Now I have X-T1 and Mk320 desn't make pre-flash. It works fine with XF lenses because they transfer f-stop data to flash unit automatically but with manual lenses there is a problem. I can't belive that potentially higher level camera can't do pre-flash. I think I'm doing something wrong but I don't know what. Someone had the same problem?

Share this post


Link to post
Share on other sites
veejaycee

I think you have a entered a setting that stops the pre-flash. Is your flash/camera set to commander mode? I think it might not preflash in commander mode because it would fire other optical slaves and give a wrong result.

Share this post


Link to post
Share on other sites
Zgubior

I've tried all available modes specialy first, "forced flash" and nothing.
Strange. I discovered that pre-flash actualy works but only when "face detection" is ON (the flash mode icon changes to eye and lightnig). This doesn't solve the problem because "face detection" can be enabled only in auto focus and continouse focus mode and I need it in manual mode.

/EDIT: I think that cause of the problem is in "red eye removal". I dont know why but it isn't working at all and "face detection" forces enebling "red eye removal". Then the "red eye removal" enables pre-flash.

Now I have to find why "red..." doesn't working.

Edited by Zgubior

Share this post


Link to post
Share on other sites
veejaycee

I didn't read your first post properly.

You are using a non - Fuji manual lens. That lens will have no electronic connection to the camera so it cannot AF, neither can it send or receive any other data to or from the camera and since the red-eye removal is linked to the AF you cannot get red-eye removal pre-flash. This would be the same with any camera when using a legacy lens without electronic connection. If you fitted the same manual lens to your X-Pro1 you will have the same problem. So, in short - it is not the camera or the flash causing the problem - it is the manual lens.

All is not lost - as you know, if you move the flash away from the lens axis you will avoid red-eye and improve the naturalness of the lighting angle. This Pixel FC-311/S 1.8 m TTL Cord for Canon will work with your XT1 and your flash and allow off camera flash with TTL. I have one for my Fujis and Fuji EF 42 flash.

https://www.amazon.co.uk/dp/B003UDFMO8/ref=pe_385721_139387541_TE_dp_1

Share this post


Link to post
Share on other sites
Zgubior

1. I think we misundertand eachother but from my fault because I had a bad assumptions.
My main purpouse was that pre-plash is necesery to properly mesure lihgt when using main fash and it turns out that's not thruth. If I'm right, pre-flash is nececery only to remove red eye and thats it. No need it at all (especially I shoot in RAW). The camera seems to take care with countig proper flash power but I'm not sure how precisely it wil deal with changing angle of flash and using difusor. We will see.

2. I have also x-pro1 and preflash works with the same manual lens. I always used that was the reason I felt lack of it in X-T1.

3. Thanks for advise about red eye removal anyway :)

4. Sorry for my bad english.

Share this post


Link to post
Share on other sites
veejaycee

You should have no problem using TTL with bounce flash or diffused flash. The camera will tell the flash to output more light to cover light loss and absorption as necessary.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recommended Discussions



×
×
  • Create New...