Jump to content
johnwillyums

X-Pro2 viewfinder blob

Recommended Posts

johnwillyums

Hi all.

I've just noticed a blob in my EVF view, it's most distracting. (X-Pro2)

I cleaned both the eyepiece, and the rectangular viewer, and changed lenses.

It seems I have a large piece of black dust in my EVF, I say this, because I can't see it in the OVF.

Also, if I use the diopter adjustment, I can bring this blob into focus, it is black, and bean shaped, with sharply defined edges.

Any suggestions how I can get this distracting object out of there?

Cheers all, John Williams :-)

 

 

Share this post


Link to post
Share on other sites
johnwillyums

Regarding this blob, I emailed Fuji, asking for advice.

They have replied by enquiring whether this blemish is visible on the LCD.

I written back letting them know that it is not visible on the LCD, nor, strangely, in the OVF. Just in the EVF mode.

I believe the EVF is a physical screen that flips in and out. When I'm in EVF mode, I can sharpen the blob with the diopter adjuster.

I think it's a physical object in there, presumably stuck to the EVF screen. It looks like a flake of black paint.

I'll see what their next communication brings.

Share this post


Link to post
Share on other sites
Christopher

Interesting! Following along.

When the EVF is engaged, I believe it is displayed by way of a prism when a curtain blocks the OVF. It's possible something has settled on that part of the optics, but that would be surprising, especially with the weather sealing.

I wonder if perhaps some pixels on the EVF display have failed?

Share this post


Link to post
Share on other sites
Damian Cook

Hi John,

I'm new here for this very thing. My brand new, boxfresh X-Pro2 has exactly the same issue. Did you ever get to an outcome/solution?

 

Share this post


Link to post
Share on other sites
Daghi

Identical problem for me. Its seems the problem happened because while traveling I lost the rubber covering the viewfinder.

No way I could find a replacement while traveling and now I have a lot of little dust in my evf. Its not appearing on pictures but its quite annoying when I see through the evf.

Did you find any solution?

I really don’t understand why this little rubber band is so loose, for a weather sealed camera this little thing is a kind of epic fail.

see the attached picture. I took it with the iphone through the vf, so low quality...sorry 

please help!

 

 

EE11A7C8-556E-4B9E-B444-69458D5E34BB.jpeg

Share this post


Link to post
Share on other sites
veejaycee

I recognised the picture of your viewfinder from your post on the DPR forum. I think the answer you got there is most likely to be correct and that you will need to send your camera in for repair since the rubber referred to is part of the weather sealing. The rubber seal itself does not appear obtainable by mere mortals.

Contact your local Fuji repair to see what if any is the charge and also the turnaround time. If the camera is relatively new they may repair free of charge since it is part of the weather sealing.

  • Like 1
  • Haha 1

Share this post


Link to post
Share on other sites
PeterRockysdad

I'm curious what happened with yours, I have the same issue now. I got quotes from Fuji for $380-700. Ridiculous methinks. See my post "Xpro 2 EVF repair issue".

Share this post


Link to post
Share on other sites
Daghi
2 hours ago, PeterRockysdad said:

I'm curious what happened with yours, I have the same issue now. I got quotes from Fuji for $380-700. Ridiculous methinks. See my post "Xpro 2 EVF repair issue".

I sent the camera to Fuji repair service. I was lucky because my camera was in the last two months warranty. They fix mine for free.

Good luck!

  • Like 1

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recommended Discussions



×
×
  • Create New...