Jump to content

Fujixuser

Members
  • Content count

    2
  • Joined

  • Last visited

Camera Gear

  • Camera List
    X100T
  1. Thanks for the reply! I’m actually feeling comfortable taking it apart. I’m wondering what cleaner to use on the sensor and possibly the low pass filter. I also think it looks like it’s on one of lens elements the way it repeats. Hopefully I can get at them!
  2. Sooo, my X100T took a bath in a river. I let it dry out for a few days, and amazingly it works. However it’s got a couple problems. First there’s a few spots showing up on some photos. It seems like shooting landscapes with a smaller aperture causes the spot to show up. The Lens was fogged up for awhile but finally cleared up. I’m guessing this might be something from the dried condensation on a lens element. Second, there is sometimes a darker area showing up on some photos in lower light. It’s in the upper left center of the photo. The two problems might be related. I don’t know for sure. It’s less noticeable in bright light and almost nonexistent in macro I sent it in to the Fujifilm repair center and the cost of repair is the price of a used replacement: $750. I don’t have the money so am contemplating disassembly and cleaning. I figure I don’t have anything to lose by trying to clean it. I looked online and found a tutorial with steps to take it apart. It looks straightforward (but not easy). I’d like to clean the sensor, low-pass filter, and the lens elements if possible. What would you recommend for cleaning each piece? I’m not sure what they’re made of and what will work on each. Any advice would be welcome. Thanks!
×